Browser Element Selection

I am trying to enter data into a field on a website. I select inspect => copy X Path, and also CSS Selector. In neither case is the element found. Is there any documentation for other methods of identifying the field?

Hello, @Hassan!

We need more information to determine the cause of this. Please send a video showing the algorithm settings, which site and item you have selected and copied its attributes. Also run the algorithm to reproduce the error.

Hi Anton,

Please find some videos. It doesn’t show some of the screens, so where screens are opened inside other screens I have tried to show what was happening with screenshots. I right click on the field where I want to
enter data (bill element 1 screenshot). Inspect => copy X Path as per bill element 2 screenshot. Paste in into DevTools as peEer copy x path video. When I run the algorithm, as per video labeled run, I get an error which says “element not interactable (Session info:
chrome=77.0.3865.120)” in the console panel on DevTools.
I couldn’t upload the videos here, so I will email them to you



Hello, @Hassan!

I tried to reproduce your error based on your algorithm, but it never showed up. It seems to be a bug.
Do you have such an error with all the elements on the page or only with this?

Then could you record one video where you describe the algorithm, show the settings, and then run it? Show the robot’s actions to the end so that the error appears. This will be very helpful, I will pass the video to the testers and they will check it.

While we’re at it, you can do the desired actions by using “Keyboard input” (using {TAB} to move between items on the page) or “Click on coordinate”.
Soon a new function will appear that will allow you to load a screenshot of the item and the robot will click on this item.

Hi Anton,
I was trying to check out other fields on the same screen, so I could tell you which other fields had the same problem, when I noticed the problem seems to have vanished. I no longer have that particular problem. However, in the same field, I try to get the element values. Working on the site manually, when I click on the “supplier” field, I see two options “Add New” and “Techboys” (attached screenshot)

However, when I try to read these values using “get element value” and “save to variable” (I have used variable “K”) I get in “K” the value Open[""] after the program has been executed… Is it possible to read the two values “Add New” and “Techboys”? If so, how?

Hello, Hassan!
I’m very glad to hear that the error has gone missing, it seems that the error appeared because of something else.

Yes, you cand find this if you click on the drop-down list icon in the Supplier field. open Developer mode (F12), click on a code of page and press Ctrl + F. Then write what are you looking for, in this case it is “Add new” or “Techboys” and you will find a code line containing this item. Then copy xPath of this line and write in to “Get element value” function to get this names.

Please, write if you have any questions.

Hi, @Hassan!

Did you find and retrieve the desired values? Or do you have any other questions?