Send Hotkey Activity

I developed a robot that downloads a file report from a website. The bot starts via Orchestrator, on a Botrunner installed on a server.
I need to launch it with RDP window minimized. I made a test and all activities are performed except “send hotkey”, when the bot try writing the file path.

There is a way for the bot to type keys without selecting an element and without selecting “use focused element”? I need a third option, only press key.



Hello @daniele_arcangeli

Can you please confirm, that you are using Send hotkey from Web automation. We face such issue when we are using GUI activity on Web.

Muhammad Hayyan Khan

1 Like

@daniele_arcangeli What is the use case here? As i understand ‘Send Hot key’ is not working as expected while writing the file path. Are you not able to pick the element (where you need to enter the file path)?

1 Like

Hi @Muhammad_Hayyan, yes i’m using Send hotkey from GUI activity!

Hey @Kudlappa_Gouder, i’m able to pick element but if i close the rdp session i got this message:

  1. Selectors: There is no screen on machine. May be RDP session is closed or minimized. If the issue persists, please refer to Help Center to make sure the activity Help Center to make sure the activity ‘Click on element’ was set up correctly.

I set “use focused element” to get around this problem but I have the same error.
Since it only has to press ctrl + v, is it possible not specify the “focus”?

1 Like

@daniele_arcangeli Did you try with these methods. We have 3 ways to deal with closed or blocked RDP.
Please try these and let me know if it works for you.
Working with a closed or blocked RDP window – ElectroNeek Help Center

1 Like

I actually launch my bots in a remote PC. I needed to lauch them even with the closed window. I realized that the remote PC blocks itself when I close the RDP window so I searched for a solution and the only one that work for me was creating a .bat file with the next code:

for /f "skip=1 tokens=3" %%s in ('query user %USERNAME%') do ( %windir%\System32\tscon.exe %%s /dest:console )

And then run it as administrator. The remote session will disconnect but your remote PC is still active and ready to run your bots. I suggest you to run this file every time you are not using your remote PC.

Hope this helps :slight_smile:


thanks @RODPOLUEN! but i’ve not administrator rights in this company server , so i cannot lauch the .bat file :smiling_face_with_tear:

1 Like

Okay, other way to connect is via Orchestrator, you have to set the credentials of your remote PC.
Check this post in this forum:

The answer provided by @dm.ferreyra was the one that helped me with setting the user and password.

Hope this helps :slight_smile:

1 Like

Hi @daniele_arcangeli, We would like to find out if the solutions we provided above worked for you. If they did, remember to mark the post that worked for you as the solution. If not, please reply in this thread with how you resolved it. That will be much appreciated.

Does the bat file need to be in the remote machine or in my machine?

In the PC where the bot is going to be launched (remote machine surely).

Before you run it, you need to execute the .bat file and then launch the bot via Orchestrator.

Hi @cris-dsc,

Just like @RODPOLUEN said, the .bat file should be inside the remote server, and should be executed right before the bot is launched via the Orchestrator.

Let us know if this works! If it does, you can mark @RODPOLUEN’s answer as a Solution.


Hello @cris-dsc, could you kindly let us know if the solutions provided by @Ivan_Ramos and @RODPOLUEN were effective?

1 Like

Hi! Does this work when launching the process via Windows Scheduler too?