Has anyone tried Studio Pro with Mac (Parallels Desktop)

I’m trying to use Studio Pro on my macbook via Parallels Desktop. And I’m getting all kinds of problems:

  1. Open URL method is not working with a very helpful error info such as “missing some parameters”.

  2. Pick new element doest work. Doesn’t retrieve any element info after I ctrl+X any element either in Chome or Edge.

  3. Process Recorder → Browser has the same problem: nothing is being recorded. Extension is installed. Tried it in Chrome.


  1. Am I doing something wrong or is it because of Paralles and Windows being simulating on Mac?
  2. Why not specify which parameters exactly is Open URL missing?

@Ivan_Agafonov You need to expand the error by clicking on > as highlighted in below screenshot to see the description of error.

Add screenshot by expanding error message.

Below are the minimum system requirement. Verify once if the VM you are using meets all system requirements mentioned below.

1 Like

Thx a lot. That arrow is very non-trivial :slightly_smiling_face:

I’ve got this extension installed, but the error think it’s not installed:

Gave this extension all the possible permissions and it worked! Not sure if that is mentioned in help or not. But probably the problem was with those permissions off by default.

@Ivan_Agafonov Thanks for highlighting this. We will review the help articles.